Raspberry BASIC

Author Topic: RPi Gitlab Setup  (Read 143 times)

John Spikowski

  • BASIC Developer
  • ***
  • Posts: 183
    • View Profile
    • ScriptBasic
RPi Gitlab Setup
« on: December 29, 2020, 11:51:49 pm »
I have installed Gitlab-ee on my new RPi 4B 8GB. The install seemed to go fine. Problem is I can't reach the Gitlab login screen.  :-\

I setup a gitlab.basic-sandbox.us DNS A record on my AWS Route53 DNS service. I have reconfigured Gitlab a couple of times with no error.

When I enter https://basic-sandbox.us in my browser it returns the Apache default index.html page.

Does anyone have an idea how to debug this to get it running?


ubuntu@rpi4b:~$ sudo gitlab-ctl status
down: alertmanager: 1s, normally up, want up; run: log: (pid 3233) 2615s
run: gitaly: (pid 3254) 2615s; run: log: (pid 3243) 2615s
run: gitlab-exporter: (pid 3239) 2615s; run: log: (pid 3232) 2615s
run: gitlab-workhorse: (pid 3259) 2615s; run: log: (pid 3250) 2615s
run: grafana: (pid 3256) 2615s; run: log: (pid 3245) 2615s
run: logrotate: (pid 3252) 2615s; run: log: (pid 3238) 2615s
run: nginx: (pid 19171) 2s; run: log: (pid 3230) 2615s
run: node-exporter: (pid 3253) 2615s; run: log: (pid 3241) 2615s
run: postgres-exporter: (pid 3249) 2615s; run: log: (pid 3234) 2615s
run: postgresql: (pid 3255) 2615s; run: log: (pid 3244) 2615s
run: prometheus: (pid 3240) 2615s; run: log: (pid 3231) 2615s
run: puma: (pid 3262) 2615s; run: log: (pid 3247) 2615s
run: redis: (pid 3251) 2615s; run: log: (pid 3235) 2615s
run: redis-exporter: (pid 3261) 2615s; run: log: (pid 3242) 2615s
run: sidekiq: (pid 3246) 2615s; run: log: (pid 3237) 2615s
ubuntu@rpi4b:~$


This is the banner that shows after logging into to RPi 4B 8GB.


Welcome to Ubuntu 20.04.1 LTS (GNU/Linux 5.4.0-1026-raspi aarch64)

 * Documentation:  https://help.ubuntu.com
 * Management:     https://landscape.canonical.com
 * Support:        https://ubuntu.com/advantage

  System information as of Tue Dec 29 18:26:42 PST 2020

  System load:  2.69                Temperature:           44.8 C
  Usage of /:   12.9% of 116.97GB   Processes:             319
  Memory usage: 66%                 Users logged in:       1
  Swap usage:   0%                  IPv4 address for eth0: 23.90.90.91

 * Introducing self-healing high availability clusters in MicroK8s.
   Simple, hardened, Kubernetes for production, from RaspberryPi to DC.

     https://microk8s.io/high-availability

0 updates can be installed immediately.
0 of these updates are security updates.

« Last Edit: December 31, 2020, 03:42:44 am by John Spikowski »
ScriptBasic Project Manager/Facilitator

John Spikowski

  • BASIC Developer
  • ***
  • Posts: 183
    • View Profile
    • ScriptBasic
Re: RPi Gitlab Setup
« Reply #1 on: December 30, 2020, 06:22:41 pm »
After doing a bit of research on my problem it seems that Apache and Nginx shouldn't be installed prior to the Gitlab install. I'm going to uninstall gitlab-ee, (Enterprise - not free) Apache and Nginx. I'm going to install Gitlab-ce (Community Edition - free) instead. Hopefully I'll have a better result.
ScriptBasic Project Manager/Facilitator

John Spikowski

  • BASIC Developer
  • ***
  • Posts: 183
    • View Profile
    • ScriptBasic
Re: RPi Gitlab Setup
« Reply #2 on: December 30, 2020, 11:53:42 pm »
My research paid off and I was able to get Gitlab-ce installed on my new RPi 4B 8GB under Ubuntu 20.04 LTS 64 bit.

I will be restoring the ScriptBasic repository (sb-dev) here soon.

The new Gitlab install is assigned to basic-sandbox.us running on fiber with a static IP.

« Last Edit: December 31, 2020, 03:44:04 am by John Spikowski »
ScriptBasic Project Manager/Facilitator

John Spikowski

  • BASIC Developer
  • ***
  • Posts: 183
    • View Profile
    • ScriptBasic
Re: RPi Gitlab Setup
« Reply #3 on: December 31, 2020, 08:05:50 pm »
I setup sb-dev on https://basic-sandbox.us/scriptbasic/sb-dev basic-sandbox.us Gitlab server running on my RPi 4B 8GB.



ScriptBasic Project Manager/Facilitator